iso7816-card.bb 767 B

1234567891011121314151617181920212223242526272829303132
  1. DESCRIPTION = "thead iso7816 card test"
  2. LICENSE = "CLOSED"
  3. COMPATIBLE_MACHINE = "light-*"
  4. SRC_URI = " \
  5. git://git@gitee.com/thead-yocto/light-libs.git;branch=master;protocol=http \
  6. "
  7. THEAD_BSP_TAG ?= "${AUTOREV}"
  8. SRCREV = "${THEAD_BSP_TAG}"
  9. S = "${WORKDIR}/git/ISO7816"
  10. export CROSS_COMPILE="riscv64-linux-"
  11. PARALLEL_MAKEINST = "-j1"
  12. do_compile() {
  13. oe_runmake
  14. }
  15. do_install() {
  16. install -d ${D}${datadir}/iso7816_card
  17. install -m 0755 ${S}/output/* ${D}${datadir}/iso7816_card
  18. install -m 0755 ${S}/*.c ${D}${datadir}/iso7816_card
  19. install -m 0755 ${S}/*.h ${D}${datadir}/iso7816_card
  20. }
  21. FILES:${PN} += " ${datadir} "
  22. PACKAGES = "${PN}"
  23. INSANE_SKIP:${PN} += " debug-files already-stripped"