thead-image-gui.bb 459 B

1234567891011121314151617181920212223
  1. DESCRIPTION = "GUI image for Light FM"
  2. LICENSE = "MIT"
  3. inherit thead-image-linux thead-image-gstreamer thead-image-gnome
  4. IMAGE_INSTALL += " \
  5. qtbase \
  6. qtsvg \
  7. qtwayland \
  8. qtgraphicaleffects \
  9. qtdeclarative \
  10. "
  11. python do_rootfs:append:riscv64 () {
  12. import subprocess
  13. srcdir=d.getVar('IMAGE_ROOTFS')
  14. cmd = 'rm -rf %s/boot/* ' % (srcdir)
  15. subprocess.check_call(cmd, shell=True)
  16. }
  17. export IMAGE_BASENAME = "thead-image-gui"