vpu-omxil-client.bb 1.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445
  1. DESCRIPTION = "Light OpenMAX IL 1.1.2 Codec clients"
  2. LICENSE = "CLOSED"
  3. COMPATIBLE_MACHINE = "light-*"
  4. SRC_URI = " \
  5. git://git@gitee.com/thead-yocto/vpu-omxil-client.git;branch=master;protocol=http \
  6. "
  7. THEAD_BSP_TAG ?= "${AUTOREV}"
  8. SRCREV = "${THEAD_BSP_TAG}"
  9. S = "${WORKDIR}/git"
  10. DEPENDS = " process-linker libomxil "
  11. RDEPENDS_${PN} = " process-linker libomxil "
  12. DEPENDS += " image-proprietary "
  13. RDEPENDS_${PN} += " image-proprietary "
  14. export SYSROOT_DIR="${PKG_CONFIG_SYSROOT_DIR}"
  15. export ARCH?="riscv"
  16. export BOARD_NAME="${MACHINEOVERRIDES}"
  17. export CROSS_COMPILE="riscv64-linux-"
  18. export TOOLCHAIN_DIR?="${EXTERNAL_TOOLCHAIN}"
  19. export LINUX_DIR?="${STAGING_KERNEL_BUILDDIR}"
  20. export PATH="/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin"
  21. export EXTRA_OEMAKE = " \
  22. INC_PATH=${PKG_CONFIG_SYSROOT_DIR}/${includedir} \
  23. LIB_PATH=${PKG_CONFIG_SYSROOT_DIR}/${libdir} \
  24. "
  25. do_install() {
  26. install -d ${D}${datadir}/omxil/test/bin
  27. install -m 0755 ${S}/output/*test ${D}${datadir}/omxil/test/bin
  28. }
  29. PACKAGES = "${PN}"
  30. FILES_${PN} = "${datadir}"
  31. INSANE_SKIP_${PN} += " debug-files "