u-boot_2020.10.bbappend 909 B

1234567891011121314151617181920212223242526272829303132333435
  1. COMPATIBLE_MACHINE = "light-*"
  2. SRC_URI = " \
  3. git://git@gitee.com/thead-yocto/u-boot.git;branch=master;protocol=http \
  4. file://fw_env.config \
  5. file://0001-no-strip-fw_printenv.patch \
  6. file://0002-Add-factory-reset-env-to-uboot.patch \
  7. file://0003-LIGHT-Automatic-version-rollback-when-upgrade-fails.patch \
  8. "
  9. THEAD_BSP_TAG ?= "${AUTOREV}"
  10. SRCREV = "${THEAD_BSP_TAG}"
  11. LICENSE = "CLOSED"
  12. do_configure_append() {
  13. mkdir ${B}/lib/
  14. cp ${S}/lib/sec_library ${B}/lib/ -rf
  15. }
  16. do_compile_append () {
  17. oe_runmake ${UBOOT_MACHINE}
  18. oe_runmake envtools
  19. }
  20. SRC_URI += "file://fw_env.config"
  21. do_install_append() {
  22. install -d ${D}${sysconfdir}
  23. install -d ${D}${bindir}
  24. install -m 0644 ${WORKDIR}/fw_env.config ${D}${sysconfdir}
  25. install -m 0755 ${B}/tools/env/fw_printenv ${D}${bindir}
  26. ln -rsf ${D}${bindir}/fw_printenv ${D}${bindir}/fw_setenv
  27. }
  28. FILES_${PN} += " ${bindir} "