light-bt.bb 1.4 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647
  1. SUMMARY = "Enable the Light bluetooth module"
  2. DESCRIPTION = "Light board bluetooth"
  3. LICENSE = "GPLv2"
  4. LIC_FILES_CHKSUM = "file://rtk_hciattach;md5=6301061798b06a2edb5e8470725ae018 \
  5. file://rtl8723d_config;md5=432f0fce7f1bafab50be9d65a5d6a632 \
  6. file://rtl8723d_fw;md5=78f647ccb55d4c7f402d8f06511e6e81"
  7. SRC_URI = "\
  8. file://light-bt.service \
  9. file://bt-init.sh \
  10. file://rtk_hciattach \
  11. file://rtl8723d_config \
  12. file://rtl8723d_fw \
  13. "
  14. inherit bin_package systemd
  15. DEPENDS:append = " update-rc.d-native"
  16. S = "${WORKDIR}"
  17. do_install () {
  18. install -d ${D}${bindir}
  19. install -d ${D}${base_libdir}/firmware/rtlbt/
  20. install -m0755 ${B}/rtk_hciattach ${D}${bindir}
  21. install -m0644 ${B}/rtl8723d_config ${D}${base_libdir}/firmware/rtlbt/
  22. install -m0644 ${B}/rtl8723d_fw ${D}${base_libdir}/firmware/rtlbt/
  23. if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
  24. install -d ${D}${systemd_system_unitdir}
  25. install -m 0644 ${WORKDIR}/light-bt.service ${D}${systemd_system_unitdir}
  26. install -d ${D}${sysconfdir}/
  27. install -m 0755 ${WORKDIR}/bt-init.sh ${D}${sysconfdir}/
  28. fi
  29. }
  30. SYSTEMD_SERVICE:${PN} = "light-bt.service"
  31. SYSTEMD_AUTO_ENABLE:${PN} = "enable"
  32. FILES:${PN} += "\
  33. ${bindir} \
  34. ${systemd_system_unitdir} \
  35. ${sysconfdir} \
  36. "
  37. FILES:${PN}-dbg += "${bindir}/.debug"