u-boot_2020.10.bbappend 859 B

1234567891011121314151617181920212223242526272829303132333435
  1. COMPATIBLE_MACHINE = "light-*"
  2. SRC_URI = " \
  3. git://git@gitee.com/thead-yocto/u-boot.git;branch=master;protocol=http \
  4. file://fw_env.config \
  5. file://0001-no-strip-fw_printenv.patch \
  6. "
  7. THEAD_BSP_TAG ?= "${AUTOREV}"
  8. THEAD_LINUX_TAG ?= "${THEAD_BSP_TAG}"
  9. SRCREV = "${THEAD_LINUX_TAG}"
  10. LICENSE = "CLOSED"
  11. do_configure:append() {
  12. mkdir ${B}/lib/
  13. cp ${S}/lib/sec_library ${B}/lib/ -rf
  14. }
  15. do_compile:append () {
  16. oe_runmake ${UBOOT_MACHINE}
  17. oe_runmake envtools
  18. }
  19. SRC_URI += "file://fw_env.config"
  20. do_install:append() {
  21. install -d ${D}${sysconfdir}
  22. install -d ${D}${bindir}
  23. install -m 0644 ${WORKDIR}/fw_env.config ${D}${sysconfdir}
  24. install -m 0755 ${B}/tools/env/fw_printenv ${D}${bindir}
  25. ln -rsf ${D}${bindir}/fw_printenv ${D}${bindir}/fw_setenv
  26. }
  27. FILES:${PN} += " ${bindir} "
  28. INSANE_SKIP:${PN} += "installed-vs-shipped"