key-input.bb 553 B

1234567891011121314151617181920212223242526
  1. SUMMARY = "TouchScreen Simulation"
  2. DESCRIPTION = "D1 board touchscreen simulation"
  3. LICENSE = "GPLv2"
  4. LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
  5. SRC_URI = "\
  6. file://ts-send.c\
  7. file://input \
  8. "
  9. # inherit bin_package
  10. S = "${WORKDIR}"
  11. do_compile() {
  12. ${CC} ts-send.c -o ts-send
  13. }
  14. do_install () {
  15. install -d ${D}${bindir}
  16. install -m0755 ${S}/input ${D}${bindir}
  17. install -m0755 ${S}/ts-send ${D}${bindir}
  18. }
  19. FILES:${PN} += " ${bindir} "
  20. FILES:${PN}-dbg += " ${bindir}/.debug "