thead-image-linux.bbclass 1.1 KB

12345678910111213141516171819202122232425262728293031323334
  1. #inherit light bsp related packages
  2. inherit thead-image-bsp
  3. #inherit grapic related packages
  4. # inherit thead-image-weston
  5. #inherit security related packages
  6. inherit thead-image-security
  7. #inherit vidio related packages, disable for public release
  8. #inherit thead-image-vision
  9. #inherit debug related packages
  10. inherit thead-image-debug
  11. #WIFI & BT related packages
  12. IMAGE_INSTALL += " wpa-supplicant bluez5 light-bt "
  13. #Android tools e.g. adb etc.
  14. IMAGE_INSTALL += " android-tools android-tools-conf "
  15. #debug tools, e.g. collecting crash image for analyzing etc.
  16. IMAGE_INSTALL += " kdump procps "
  17. #multi-media related support
  18. IMAGE_INSTALL += " alsa-utils alsa-lib alsa-tools pulseaudio-server "
  19. IMAGE_INSTALL += " ffmpeg "
  20. # produce utils
  21. IMAGE_INSTALL += " prd-utils "
  22. IMAGE_INSTALL += " sqlite3 "
  23. # enable for public release
  24. IMAGE_INSTALL:remove = "csi-hal-vcodec rambus-os-ik-150 gpu-bxm-4-64 npu-ax3386 thead-fce "
  25. IMAGE_INSTALL:remove = "thead-ddr-pmu isp-isp8000l libgal-viv libcsi-g2d vpu-omxil "
  26. IMAGE_INSTALL += " image-proprietary "
  27. #IMAGE_FSTYPES:remove = "cpio.gz cpio cpio.gz.u-boot cpio.bz2"