thead-image-gnome.bbclass 952 B

1234567891011121314151617181920212223242526272829303132333435
  1. IMAGE_INSTALL += " \
  2. packagegroup-core-x11 \
  3. packagegroup-core-x11-base \
  4. packagegroup-core-x11-xserver \
  5. packagegroup-gnome-desktop3 \
  6. glmark2 \
  7. mixbench \
  8. net-tools \
  9. alsa-utils \
  10. gpgme \
  11. gnupg \
  12. gpu-bxm-4-64 \
  13. gpu-bxm-4-64-gpl \
  14. utouch-evemu \
  15. kmscube \
  16. haveged \
  17. gnome-settings-daemon \
  18. packagegroup-gnome-apps3-dev \
  19. packagegroup-gnome-desktop3-dev \
  20. "
  21. # gnome-shell_42.0 need install
  22. # IMAGE_INSTALL += "gnome-shell-gsettings"
  23. # remove "vkmark \" after glmark2 because build error, to fix it,
  24. # /usr/include/vulkan/vulkan.hpp should exists on build host,
  25. # and fix it by install libvulkan-dev packet on host.
  26. inherit core-image features_check
  27. IMAGE_FEATURES += "dev-pkgs ssh-server-openssh"
  28. REQUIRED_DISTRO_FEATURES = "x11 wayland opengl vulkan opencl"
  29. PREFERERRED_VERSION_llvm = "10.0.2"
  30. # IMAGE_ROOTFS_EXTRA_SPACE = "10240"
  31. SYSTEMD_DEFAULT_TARGET = "graphical.target"