gdbserver-external.bb 963 B

12345678910111213141516171819202122232425262728
  1. SUMMARY = "gdbserver is a program that allows you to run GDB on a different machine than the one which is running the program being debugged"
  2. HOMEPAGE = "http://www.gnu.org/software/gdb/"
  3. SECTION = "devel"
  4. PV := "${@external_run(d, 'gdb', '-v').splitlines()[0].split()[-1]}"
  5. inherit external-toolchain
  6. def get_gdb_license(d):
  7. output = external_run(d, 'gdb', '-v')
  8. if output != 'UNKNOWN':
  9. for line in output.splitlines():
  10. if line.startswith('License '):
  11. lic = line.split(':', 1)[0]
  12. return lic.replace('License ', '')
  13. else:
  14. return output
  15. LICENSE := "${@get_gdb_license(d)}"
  16. LICENSE[vardepvalue] = "${LICENSE}"
  17. FILES:${PN} = "${bindir}/gdbserver"
  18. FILES:${PN}-doc = "${mandir}/man1/gdbserver.1"
  19. # Ensure that our rdeps are able to be set by shlibs processing
  20. do_package[depends] += "\
  21. virtual/libc:do_packagedata \
  22. virtual/${MLPREFIX}${TARGET_PREFIX}compilerlibs:do_packagedata \
  23. "