libgfortran-external.bb 1.1 KB

12345678910111213141516171819202122232425262728
  1. SUMMARY = "The GNU Compiler Collection - libgfortran"
  2. HOMEPAGE = "http://www.gnu.org/software/gcc/"
  3. SECTION = "devel"
  4. PV = "${GCC_VERSION}"
  5. inherit external-toolchain
  6. LICENSE = "GPL-3.0-with-GCC-exception"
  7. external_libroot = "${@os.path.realpath('${EXTERNAL_TOOLCHAIN_LIBROOT}').replace(os.path.realpath('${EXTERNAL_TOOLCHAIN}') + '/', '/')}"
  8. FILES_MIRRORS =. "${libdir}/gcc/${TARGET_SYS}/${GCC_VERSION}/|${external_libroot}/\n"
  9. EXTERNAL_PROVIDE_PATTERN = "${FILES_${PN}}"
  10. # We don't copy the static binaries and headers, since they don't belong to the
  11. # target sysroot, but need to be in the native one (that's the place where compiler
  12. # and linker are looking for them).
  13. FILES:${PN} = "${libdir}/libgfortran.so.*"
  14. FILES:${PN}-dev = "\
  15. ${libdir}/libgfortran*.so \
  16. ${libdir}/libgfortran.spec \
  17. ${libdir}/libgfortran.la \
  18. "
  19. FILES:${PN}-staticdev = "${libdir}/libgfortran.a"
  20. do_package_write_ipk[depends] += "virtual/${MLPREFIX}libc:do_packagedata"
  21. do_package_write_deb[depends] += "virtual/${MLPREFIX}libc:do_packagedata"
  22. do_package_write_rpm[depends] += "virtual/${MLPREFIX}libc:do_packagedata"