gcc_%.bbappend 477 B

12345678910
  1. # FIXME: resolve gcc version mismatch issues with ${libdir}/gcc/*/<version>
  2. # filesystem paths
  3. python () {
  4. if d.getVar('EXTERNAL_ENABLED'):
  5. # unwind.h will come from libgcc-external, we don't want to try to pull it
  6. # from the cross area of the sysroot
  7. inst = d.getVar('do_install', False).splitlines()
  8. inst = filter(lambda l: not ('unwind.h' in l and '${STAGING_LIBDIR_NATIVE}' in l), inst)
  9. d.setVar('do_install', '\n'.join(inst))
  10. }