riscv-initramfs-image.bb 680 B

123456789101112131415161718192021222324
  1. DESCRIPTION = "initramfs image to be used together with SiFive Unleashed board \
  2. as the board currently only supports booting from a ramdisk image"
  3. # Do not pollute the initrd image with rootfs features
  4. IMAGE_FEATURES = ""
  5. export IMAGE_BASENAME = "${MLPREFIX}riscv-initramfs-image"
  6. IMAGE_LINGUAS = ""
  7. LICENSE = "MIT"
  8. IMAGE_INSTALL += "initscripts-readonly-rootfs-overlay "
  9. IMAGE_FSTYPES += "${INITRAMFS_FSTYPES}"
  10. inherit core-image
  11. IMAGE_ROOTFS_SIZE = "8192"
  12. IMAGE_ROOTFS_EXTRA_SPACE = "0"
  13. BAD_RECOMMENDATIONS += "busybox-syslog"
  14. # WIC is not compatible with an initramfs image, also enabling WIC would cause
  15. # an circular dependency.
  16. IMAGE_FSTYPES_remove = " wic wic.gz"