light-fm-image-weston.bb 884 B

12345678910111213141516171819202122232425262728293031323334353637383940
  1. DESCRIPTION = "Weston Image for Light FM"
  2. LICENSE = "MIT"
  3. IMAGE_INSTALL += "packagegroup-core-boot \
  4. kernel-modules \
  5. weston \
  6. gtk+3 \
  7. gpgme \
  8. gnupg \
  9. gpu-bxm-4-64-gpl \
  10. haveged \
  11. util-linux \
  12. gfx-examples \
  13. tiff \
  14. skia \
  15. initscripts-readonly-rootfs-overlay \
  16. tzdata \
  17. "
  18. inherit core-image features_check
  19. python do_rootfs_append_riscv64 () {
  20. import subprocess
  21. srcdir=d.getVar('IMAGE_ROOTFS')
  22. cmd = 'rm -rf %s/boot/* ' % (srcdir)
  23. subprocess.check_call(cmd, shell=True)
  24. }
  25. REQUIRED_DISTRO_FEATURES = "wayland opengl vulkan opencl"
  26. IMAGE_FEATURES += "dev-pkgs ssh-server-openssh"
  27. DISTRO_FEATURES_remove = " x11"
  28. PREFERERRED_VERSION_mesa = "21.0.1"
  29. PREFERERRED_VERSION_llvm = "10.0.2"
  30. #IMAGE_ROOTFS_EXTRA_SPACE = "10240"
  31. SYSTEMD_DEFAULT_TARGET = "graphical.target"
  32. export IMAGE_BASENAME = "light-fm-image-weston"