light-fm-image-tools.bb 747 B

1234567891011121314151617181920212223242526
  1. DESCRIPTION = "This image used for compiling test tools only."
  2. LICENSE = "MIT"
  3. IMAGE_INSTALL += " util-linux openssl e2fsprogs "
  4. IMAGE_INSTALL += " cpupower cpufrequtils "
  5. IMAGE_INSTALL += " kmscube glmark2 vkmark mixbench "
  6. IMAGE_INSTALL += " memtool curl tcpdump usbutils mmc-utils net-tools iw perf iperf2 gdb strace netperf "
  7. IMAGE_INSTALL += " initscripts-readonly-rootfs-overlay "
  8. IMAGE_INSTALL += " tzdata "
  9. python do_rootfs_append_riscv64 () {
  10. import subprocess
  11. srcdir=d.getVar('IMAGE_ROOTFS')
  12. cmd = 'rm -rf %s/boot/* ' % (srcdir)
  13. subprocess.check_call(cmd, shell=True)
  14. }
  15. #DISTRO_FEATURES_remove = " ipv6 pcmcia usbgadget usbhost pci 3g nfc vfat "
  16. export IMAGE_BASENAME = "light-fm-image-tools"
  17. inherit core-image