light-fm-image-security.bb 446 B

12345678910111213141516171819
  1. DESCRIPTION = "A security image for light fm."
  2. IMAGE_INSTALL += "packagegroup-core-boot kernel-modules op-tee initscripts-readonly-rootfs-overlay"
  3. IMAGE_INSTALL += "tzdata"
  4. LICENSE = "MIT"
  5. python do_rootfs_append_riscv64 () {
  6. import subprocess
  7. srcdir=d.getVar('IMAGE_ROOTFS')
  8. cmd = 'rm -rf %s/boot/* ' % (srcdir)
  9. subprocess.check_call(cmd, shell=True)
  10. }
  11. export IMAGE_BASENAME = "light-fm-image-security"
  12. inherit core-image