light-fm-image-minimal.bb 542 B

12345678910111213141516171819202122
  1. DESCRIPTION = "A minimal image for light fm."
  2. IMAGE_INSTALL = "packagegroup-core-boot kernel-modules"
  3. IMAGE_INSTALL += " resizefs initscripts-readonly-rootfs-overlay "
  4. IMAGE_INSTALL += "tzdata"
  5. LICENSE = "MIT"
  6. python do_rootfs_append_riscv64 () {
  7. import subprocess
  8. srcdir=d.getVar('IMAGE_ROOTFS')
  9. cmd = 'rm -rf %s/boot/* ' % (srcdir)
  10. subprocess.check_call(cmd, shell=True)
  11. }
  12. DISTRO_FEATURES_remove = " ipv6 pcmcia usbgadget usbhost pci 3g nfc vfat "
  13. export IMAGE_BASENAME = "light-fm-image-minimal"
  14. inherit core-image