light-extend-debs.bb 519 B

12345678910111213141516171819202122
  1. DESCRIPTION = "This image includes light extend debs."
  2. LICENSE = "MIT"
  3. IMAGE_INSTALL += " python3 python3-numpy python3-pip python3-psutil python3-ruamel-yaml python3-pytest python3-lxml "
  4. python do_rootfs_append_riscv64 () {
  5. import subprocess
  6. srcdir=d.getVar('IMAGE_ROOTFS')
  7. cmd = 'rm -rf %s/boot/* ' % (srcdir)
  8. subprocess.check_call(cmd, shell=True)
  9. }
  10. #DISTRO_FEATURES_remove = " ipv6 pcmcia usbgadget usbhost pci 3g nfc vfat "
  11. export IMAGE_BASENAME = "light-extend-debs"
  12. inherit core-image