xuser-account_0.1.bb 675 B

12345678910111213141516171819202122232425262728
  1. SUMMARY = "Creates an 'xuser' account used for running X11"
  2. LICENSE = "MIT"
  3. LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
  4. SRC_URI = "file://system-xuser.conf"
  5. inherit allarch useradd
  6. do_configure() {
  7. :
  8. }
  9. do_compile() {
  10. :
  11. }
  12. do_install() {
  13. install -D -m 0644 ${WORKDIR}/system-xuser.conf ${D}${sysconfdir}/dbus-1/system.d/system-xuser.conf
  14. }
  15. FILES_${PN} = "${sysconfdir}/dbus-1/system.d/system-xuser.conf"
  16. USERADD_PACKAGES = "${PN}"
  17. USERADD_PARAM_${PN} = "--create-home \
  18. --groups video,tty,audio,input,shutdown,disk \
  19. --user-group xuser"
  20. ALLOW_EMPTY_${PN} = "1"