libpcre_8.44.bb 2.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475
  1. DESCRIPTION = "The PCRE library is a set of functions that implement regular \
  2. expression pattern matching using the same syntax and semantics as Perl 5. PCRE \
  3. has its own native API, as well as a set of wrapper functions that correspond \
  4. to the POSIX regular expression API."
  5. SUMMARY = "Perl Compatible Regular Expressions"
  6. HOMEPAGE = "http://www.pcre.org"
  7. SECTION = "devel"
  8. LICENSE = "BSD-3-Clause"
  9. LIC_FILES_CHKSUM = "file://LICENCE;md5=3bb381a66a5385b246d4877922e7511e"
  10. SRC_URI = "https://ftp.pcre.org/pub/pcre/pcre-${PV}.tar.bz2 \
  11. file://fix-pcre-name-collision.patch \
  12. file://run-ptest \
  13. file://Makefile \
  14. "
  15. SRC_URI[md5sum] = "cf7326204cc46c755b5b2608033d9d24"
  16. SRC_URI[sha256sum] = "19108658b23b3ec5058edc9f66ac545ea19f9537234be1ec62b714c84399366d"
  17. CVE_PRODUCT = "pcre"
  18. S = "${WORKDIR}/pcre-${PV}"
  19. PROVIDES += "pcre"
  20. DEPENDS += "bzip2 zlib"
  21. PACKAGECONFIG ??= "pcre8 unicode-properties jit"
  22. PACKAGECONFIG[pcre8] = "--enable-pcre8,--disable-pcre8"
  23. PACKAGECONFIG[pcre16] = "--enable-pcre16,--disable-pcre16"
  24. PACKAGECONFIG[pcre32] = "--enable-pcre32,--disable-pcre32"
  25. PACKAGECONFIG[pcretest-readline] = "--enable-pcretest-libreadline,--disable-pcretest-libreadline,readline,"
  26. PACKAGECONFIG[unicode-properties] = "--enable-unicode-properties,--disable-unicode-properties"
  27. PACKAGECONFIG[jit] = "--enable-jit=auto,--disable-jit"
  28. BINCONFIG = "${bindir}/pcre-config"
  29. inherit autotools binconfig-disabled ptest
  30. EXTRA_OECONF = "--enable-utf"
  31. PACKAGES =+ "libpcrecpp libpcreposix pcregrep pcregrep-doc pcretest pcretest-doc"
  32. SUMMARY_libpcrecpp = "${SUMMARY} - C++ wrapper functions"
  33. SUMMARY_libpcreposix = "${SUMMARY} - C wrapper functions based on the POSIX regex API"
  34. SUMMARY_pcregrep = "grep utility that uses perl 5 compatible regexes"
  35. SUMMARY_pcregrep-doc = "grep utility that uses perl 5 compatible regexes - docs"
  36. SUMMARY_pcretest = "program for testing Perl-comatible regular expressions"
  37. SUMMARY_pcretest-doc = "program for testing Perl-comatible regular expressions - docs"
  38. FILES_libpcrecpp = "${libdir}/libpcrecpp.so.*"
  39. FILES_libpcreposix = "${libdir}/libpcreposix.so.*"
  40. FILES_pcregrep = "${bindir}/pcregrep"
  41. FILES_pcregrep-doc = "${mandir}/man1/pcregrep.1"
  42. FILES_pcretest = "${bindir}/pcretest"
  43. FILES_pcretest-doc = "${mandir}/man1/pcretest.1"
  44. BBCLASSEXTEND = "native nativesdk"
  45. do_install_ptest() {
  46. t=${D}${PTEST_PATH}
  47. cp ${WORKDIR}/Makefile $t
  48. cp -r ${S}/testdata $t
  49. for i in pcre_stringpiece_unittest pcregrep pcretest; \
  50. do cp ${B}/.libs/$i $t; \
  51. done
  52. for i in RunTest RunGrepTest test-driver; \
  53. do cp ${S}/$i $t; \
  54. done
  55. # Skip the fr_FR locale test. If the locale fr_FR is found, it is tested.
  56. # If not found, the test is skipped. The test program assumes fr_FR is non-UTF-8
  57. # locale so the test fails if fr_FR is UTF-8 locale.
  58. sed -i -e 's:do3=yes:do3=no:g' ${D}${PTEST_PATH}/RunTest
  59. }
  60. RDEPENDS_${PN}-ptest += "make"