libpcre2_10.35.bb 1.8 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152
  1. DESCRIPTION = "There are two major versions of the PCRE library. The \
  2. newest version is PCRE2, which is a re-working of the original PCRE \
  3. library to provide an entirely new API. The original, very widely \
  4. deployed PCRE library's API and feature are stable, future releases \
  5. will be for bugfixes only. All new future features will be to PCRE2, \
  6. not the original PCRE 8.x series."
  7. SUMMARY = "Perl Compatible Regular Expressions version 2"
  8. HOMEPAGE = "http://www.pcre.org"
  9. SECTION = "devel"
  10. LICENSE = "BSD-3-Clause"
  11. LIC_FILES_CHKSUM = "file://LICENCE;md5=a06590e9bd4c229532364727aaeaf084"
  12. SRC_URI = "https://ftp.pcre.org/pub/pcre/pcre2-${PV}.tar.bz2"
  13. SRC_URI[sha256sum] = "9ccba8e02b0ce78046cdfb52e5c177f0f445e421059e43becca4359c669d4613"
  14. CVE_PRODUCT = "pcre2"
  15. S = "${WORKDIR}/pcre2-${PV}"
  16. PROVIDES += "pcre2"
  17. DEPENDS += "bzip2 zlib"
  18. BINCONFIG = "${bindir}/pcre2-config"
  19. inherit autotools binconfig-disabled
  20. EXTRA_OECONF = "\
  21. --enable-newline-is-lf \
  22. --with-link-size=2 \
  23. --with-match-limit=10000000 \
  24. --enable-pcre2-16 \
  25. --enable-pcre2-32 \
  26. "
  27. CFLAGS += "-D_REENTRANT"
  28. CXXFLAGS_append_powerpc = " -lstdc++"
  29. PACKAGES =+ "libpcre2-16 libpcre2-32 pcre2grep pcre2grep-doc pcre2test pcre2test-doc"
  30. SUMMARY_pcre2grep = "grep utility that uses perl 5 compatible regexes"
  31. SUMMARY_pcre2grep-doc = "grep utility that uses perl 5 compatible regexes - docs"
  32. SUMMARY_pcre2test = "program for testing Perl-comatible regular expressions"
  33. SUMMARY_pcre2test-doc = "program for testing Perl-comatible regular expressions - docs"
  34. FILES_libpcre2-16 = "${libdir}/libpcre2-16.so.*"
  35. FILES_libpcre2-32 = "${libdir}/libpcre2-32.so.*"
  36. FILES_pcre2grep = "${bindir}/pcre2grep"
  37. FILES_pcre2grep-doc = "${mandir}/man1/pcre2grep.1"
  38. FILES_pcre2test = "${bindir}/pcre2test"
  39. FILES_pcre2test-doc = "${mandir}/man1/pcre2test.1"
  40. BBCLASSEXTEND = "native nativesdk"