libgpg-error_1.39.bb 1.4 KB

12345678910111213141516171819202122232425262728293031323334353637383940
  1. SUMMARY = "Small library that defines common error values for all GnuPG components"
  2. HOMEPAGE = "http://www.gnupg.org/related_software/libgpg-error/"
  3. BUGTRACKER = "https://bugs.g10code.com/gnupg/index"
  4. LICENSE = "GPLv2+ & LGPLv2.1+"
  5. LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552 \
  6. file://COPYING.LIB;md5=2d5025d4aa3495befef8f17206a5b0a1 \
  7. file://src/gpg-error.h.in;beginline=2;endline=18;md5=d82591bc81561f617da71e00ff4a9d79 \
  8. file://src/init.c;beginline=2;endline=17;md5=f01cdfcf747af5380590cfd9bbfeaaf7 \
  9. "
  10. SECTION = "libs"
  11. UPSTREAM_CHECK_URI = "https://gnupg.org/download/index.html"
  12. SRC_URI = "${GNUPG_MIRROR}/libgpg-error/libgpg-error-${PV}.tar.bz2 \
  13. file://pkgconfig.patch \
  14. file://0001-Do-not-fail-when-testing-config-scripts.patch \
  15. "
  16. SRC_URI[sha256sum] = "4a836edcae592094ef1c5a4834908f44986ab2b82e0824a0344b49df8cdb298f"
  17. BINCONFIG = "${bindir}/gpg-error-config"
  18. inherit autotools binconfig-disabled pkgconfig gettext multilib_header multilib_script
  19. MULTILIB_SCRIPTS = "${PN}-dev:${bindir}/gpgrt-config"
  20. CPPFLAGS += "-P"
  21. do_install_append() {
  22. # we don't have common lisp in OE
  23. rm -rf "${D}${datadir}/common-lisp/"
  24. oe_multilib_header gpg-error.h gpgrt.h
  25. }
  26. FILES_${PN}-dev += "${bindir}/gpg-error"
  27. FILES_${PN}-doc += "${datadir}/libgpg-error/errorref.txt"
  28. BBCLASSEXTEND = "native nativesdk"