libffi_3.3.bb 2.0 KB

1234567891011121314151617181920212223242526272829303132333435363738394041
  1. SUMMARY = "A portable foreign function interface library"
  2. HOMEPAGE = "http://sourceware.org/libffi/"
  3. DESCRIPTION = "The `libffi' library provides a portable, high level programming interface to various calling \
  4. conventions. This allows a programmer to call any function specified by a call interface description at run \
  5. time. FFI stands for Foreign Function Interface. A foreign function interface is the popular name for the \
  6. interface that allows code written in one language to call code written in another language. The `libffi' \
  7. library really only provides the lowest, machine dependent layer of a fully featured foreign function interface. \
  8. A layer must exist above `libffi' that handles type conversions for values passed between the two languages."
  9. LICENSE = "MIT"
  10. LIC_FILES_CHKSUM = "file://LICENSE;md5=492385fe22195952f5b9b197868ba268"
  11. SRC_URI = "https://github.com/libffi/libffi/releases/download/v${PV}/${BPN}-${PV}.tar.gz \
  12. file://not-win32.patch \
  13. file://0001-Fixed-missed-ifndef-for-__mips_soft_float.patch \
  14. file://0001-powerpc-fix-build-failure-on-power7-and-older-532.patch \
  15. file://0001-Address-platforms-with-no-__int128.patch \
  16. file://0001-Address-platforms-with-no-__int128-part2.patch \
  17. file://0001-ffi_powerpc.h-fix-build-failure-with-powerpc7.patch \
  18. "
  19. SRC_URI[md5sum] = "6313289e32f1d38a9df4770b014a2ca7"
  20. SRC_URI[sha256sum] = "72fba7922703ddfa7a028d513ac15a85c8d54c8d67f55fa5a4802885dc652056"
  21. UPSTREAM_CHECK_URI = "https://github.com/libffi/libffi/releases/"
  22. UPSTREAM_CHECK_REGEX = "libffi-(?P<pver>\d+(\.\d+)+)\.tar"
  23. EXTRA_OECONF += "--disable-builddir"
  24. EXTRA_OEMAKE_class-target = "LIBTOOLFLAGS='--tag=CC'"
  25. inherit autotools texinfo multilib_header
  26. do_install_append() {
  27. oe_multilib_header ffi.h ffitarget.h
  28. }
  29. FILES_${PN}-dev += "${libdir}/libffi-${PV}"
  30. # Doesn't compile in MIPS16e mode due to use of hand-written
  31. # assembly
  32. MIPS_INSTRUCTION_SET = "mips"
  33. BBCLASSEXTEND = "native nativesdk"