libevent_2.1.12.bb 1.6 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556
  1. SUMMARY = "An asynchronous event notification library"
  2. HOMEPAGE = "http://libevent.org/"
  3. BUGTRACKER = "https://github.com/libevent/libevent/issues"
  4. SECTION = "libs"
  5. LICENSE = "BSD & MIT"
  6. LIC_FILES_CHKSUM = "file://LICENSE;md5=17f20574c0b154d12236d5fbe964f549"
  7. SRC_URI = "https://github.com/libevent/libevent/releases/download/release-${PV}-stable/${BP}-stable.tar.gz \
  8. file://Makefile-missing-test-dir.patch \
  9. file://run-ptest \
  10. file://0001-test-regress_dns.c-patch-out-tests-that-require-a-wo.patch \
  11. "
  12. SRC_URI[sha256sum] = "92e6de1be9ec176428fd2367677e61ceffc2ee1cb119035037a27d346b0403bb"
  13. UPSTREAM_CHECK_URI = "http://libevent.org/"
  14. S = "${WORKDIR}/${BPN}-${PV}-stable"
  15. PACKAGECONFIG ??= ""
  16. PACKAGECONFIG[openssl] = "--enable-openssl,--disable-openssl,openssl"
  17. inherit autotools
  18. # Needed for Debian packaging
  19. LEAD_SONAME = "libevent-2.1.so"
  20. inherit ptest multilib_header
  21. DEPENDS = "zlib"
  22. PACKAGES_DYNAMIC = "^${PN}-.*$"
  23. python split_libevent_libs () {
  24. do_split_packages(d, '${libdir}', r'^libevent_([a-z]*)-.*\.so\..*', '${PN}-%s', '${SUMMARY} (%s)', prepend=True, allow_links=True)
  25. }
  26. PACKAGESPLITFUNCS_prepend = "split_libevent_libs "
  27. BBCLASSEXTEND = "native nativesdk"
  28. do_install_append() {
  29. rm ${D}${bindir}/event_rpcgen.py
  30. rmdir ${D}${bindir}
  31. oe_multilib_header event2/event-config.h
  32. }
  33. do_install_ptest() {
  34. install -d ${D}${PTEST_PATH}/test
  35. for file in ${B}/test/.libs/regress ${B}/test/.libs/test*
  36. do
  37. install -m 0755 $file ${D}${PTEST_PATH}/test
  38. done
  39. # handle multilib
  40. sed -i s:@libdir@:${libdir}:g ${D}${PTEST_PATH}/run-ptest
  41. }