dos2unix_7.4.2.bb 1.1 KB

12345678910111213141516171819202122232425262728293031323334
  1. SUMMARY = "Convert text file line endings between CRLF and LF"
  2. DESCRIPTION = "The Dos2unix package includes utilities dos2unix and \
  3. unix2dos to convert plain text files in DOS or Mac format to Unix \
  4. format and vice versa."
  5. HOMEPAGE = "http://waterlan.home.xs4all.nl/dos2unix.html"
  6. SECTION = "support"
  7. LICENSE = "BSD-2-Clause"
  8. LIC_FILES_CHKSUM = "file://COPYING.txt;md5=8a7c3499a1142df819e727253cd53a12"
  9. SRC_URI = "git://git.code.sf.net/p/dos2unix/dos2unix"
  10. UPSTREAM_CHECK_GITTAGREGEX = "dos2unix-(?P<pver>(\d+(\.\d+)+))"
  11. SRCREV = "72596f0ae21faa25a07a872d4843bc885475115d"
  12. S = "${WORKDIR}/git/dos2unix"
  13. inherit gettext perlnative
  14. # The dos2unix NLS relies on po4a-native, while po4a recipe is
  15. # provided by meta-perl layer, so make it optional here, you
  16. # need have meta-perl in bblayers.conf before enabling nls in
  17. # PACKAGECONFIG.
  18. PACKAGECONFIG ??= ""
  19. PACKAGECONFIG[nls] = "ENABLE_NLS=1,ENABLE_NLS=,po4a-native"
  20. EXTRA_OEMAKE = "${PACKAGECONFIG_CONFARGS} LDFLAGS_USER='${LDFLAGS}'"
  21. EXTRA_OEMAKE_class-native = "ENABLE_NLS="
  22. do_install () {
  23. oe_runmake DESTDIR="${D}${base_prefix}" install
  24. }
  25. BBCLASSEXTEND = "native nativesdk"