argp-standalone_1.3.bb 1.0 KB

1234567891011121314151617181920212223242526272829303132
  1. # Copyright (C) 2015 Khem Raj <raj.khem@gmail.com>
  2. # Released under the MIT license (see COPYING.MIT for the terms)
  3. SUMMARY = "Glibc hierarchical argument parsing standalone library"
  4. HOMEPAGE = "http://www.lysator.liu.se/~nisse/misc/"
  5. LICENSE = "LGPL-2.1"
  6. LIC_FILES_CHKSUM = "file://argp.h;beginline=1;endline=20;md5=008b7e53dea6f9e1d9fdef0d9cf3184a"
  7. SECTION = "libs"
  8. SRC_URI = "http://www.lysator.liu.se/~nisse/misc/argp-standalone-${PV}.tar.gz \
  9. file://0001-throw-in-funcdef.patch \
  10. file://0002-isprint.patch \
  11. file://out_of_tree_build.patch \
  12. "
  13. SRC_URI[md5sum] = "720704bac078d067111b32444e24ba69"
  14. SRC_URI[sha256sum] = "dec79694da1319acd2238ce95df57f3680fea2482096e483323fddf3d818d8be"
  15. inherit autotools
  16. CFLAGS += "-fPIC -U__OPTIMIZE__"
  17. RDEPENDS_${PN}-dev = ""
  18. RDEPENDS_${PN}-staticdev = ""
  19. do_install() {
  20. install -D -m 0644 ${B}/libargp.a ${D}${libdir}/libargp.a
  21. install -D -m 0644 ${S}/argp.h ${D}${includedir}/argp.h
  22. }
  23. #
  24. # We will skip parsing for non-musl systems
  25. #
  26. COMPATIBLE_HOST = ".*-musl.*"