sato-screenshot_0.3.bb 919 B

12345678910111213141516171819202122232425262728
  1. SUMMARY = "Ultra-simple screen capture utility, aimed at handheld devices"
  2. HOMEPAGE = "http://www.o-hand.com"
  3. BUGTRACKER = "http://bugzilla.yoctoproject.org/"
  4. LICENSE = "GPLv2 & GPLv2+"
  5. LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
  6. file://main.c;endline=9;md5=023e14d6404d0a961eb97cbd011fc141 \
  7. file://screenshot-ui.h;endline=9;md5=638d9ffa83e9325a36df224166ed6ad0"
  8. DEPENDS = "matchbox-panel-2 gtk+3"
  9. # SRCREV tagged 0.3
  10. SRCREV = "9250fa5a012d84ff45984e8c4345ee7635227756"
  11. SRC_URI = "git://git.yoctoproject.org/screenshot"
  12. UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>(\d+(\.\d+)+))"
  13. S = "${WORKDIR}/git"
  14. inherit autotools pkgconfig features_check
  15. FILES_${PN} += "${libdir}/matchbox-panel/*.so"
  16. do_install_append () {
  17. rm -f ${D}${libdir}/matchbox-panel/*.la
  18. }
  19. # The matchbox-panel-2 requires x11 in DISTRO_FEATURES
  20. REQUIRED_DISTRO_FEATURES = "x11"