core-image-sato-ptest-fast.bb 765 B

12345678910111213141516171819
  1. require core-image-sato-sdk.bb
  2. require conf/distro/include/ptest-packagelists.inc
  3. IMAGE_INSTALL += "${PTESTS_FAST}"
  4. DESCRIPTION += "Also includes ptest packages with fast execution times to allow for more automated QA."
  5. # This image is sufficiently large (~1.8GB) that it can't actually fit in a live
  6. # image (which has a 4GB limit), so nullify the overhead factor (1.3x out of the
  7. # box) and explicitly add just 1500MB.
  8. # strace-ptest in particular needs more than 500MB
  9. IMAGE_OVERHEAD_FACTOR = "1.0"
  10. IMAGE_ROOTFS_EXTRA_SPACE = "1524288"
  11. # ptests need more memory than standard to avoid the OOM killer
  12. QB_MEM = "-m 1024"
  13. # Sadly at the moment the fast set of ptests is not robust enough and sporadically fails in a couple of places
  14. PTEST_EXPECT_FAILURE = "1"