libwebp_1.1.0.bb 2.2 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556
  1. SUMMARY = "WebP is an image format designed for the Web"
  2. DESCRIPTION = "WebP is a method of lossy and lossless compression that can be \
  3. used on a large variety of photographic, translucent and \
  4. graphical images found on the web. The degree of lossy \
  5. compression is adjustable so a user can choose the trade-off \
  6. between file size and image quality. WebP typically achieves \
  7. an average of 30% more compression than JPEG and JPEG 2000, \
  8. without loss of image quality."
  9. HOMEPAGE = "https://developers.google.com/speed/webp/"
  10. SECTION = "libs"
  11. LICENSE = "BSD-3-Clause"
  12. LIC_FILES_CHKSUM = "file://COPYING;md5=6e8dee932c26f2dab503abf70c96d8bb \
  13. file://PATENTS;md5=c6926d0cb07d296f886ab6e0cc5a85b7"
  14. SRC_URI = "http://downloads.webmproject.org/releases/webp/${BP}.tar.gz"
  15. SRC_URI[md5sum] = "7e047f2cbaf584dff7a8a7e0f8572f18"
  16. SRC_URI[sha256sum] = "98a052268cc4d5ece27f76572a7f50293f439c17a98e67c4ea0c7ed6f50ef043"
  17. UPSTREAM_CHECK_URI = "http://downloads.webmproject.org/releases/webp/index.html"
  18. EXTRA_OECONF = " \
  19. --disable-wic \
  20. --enable-libwebpmux \
  21. --enable-libwebpdemux \
  22. --enable-threading \
  23. "
  24. # Do not trust configure to determine if neon is available.
  25. #
  26. EXTRA_OECONF_ARM = " \
  27. ${@bb.utils.contains("TUNE_FEATURES","neon","--enable-neon","--disable-neon",d)} \
  28. "
  29. EXTRA_OECONF_append_arm = " ${EXTRA_OECONF_ARM}"
  30. EXTRA_OECONF_append_armeb = " ${EXTRA_OECONF_ARM}"
  31. inherit autotools lib_package
  32. PACKAGECONFIG ??= ""
  33. # libwebpdecoder is a subset of libwebp, don't build it unless requested
  34. PACKAGECONFIG[decoder] = "--enable-libwebpdecoder,--disable-libwebpdecoder"
  35. # Apply for examples programs: cwebp and dwebp
  36. PACKAGECONFIG[gif] = "--enable-gif,--disable-gif,giflib"
  37. PACKAGECONFIG[jpeg] = "--enable-jpeg,--disable-jpeg,jpeg"
  38. PACKAGECONFIG[png] = "--enable-png,--disable-png,,libpng"
  39. PACKAGECONFIG[tiff] = "--enable-tiff,--disable-tiff,tiff"
  40. # Apply only for example program vwebp
  41. PACKAGECONFIG[gl] = "--enable-gl,--disable-gl,mesa-glut"
  42. PACKAGES =+ "${PN}-gif2webp"
  43. DESCRIPTION_${PN}-gif2webp = "Simple tool to convert animated GIFs to WebP"
  44. FILES_${PN}-gif2webp = "${bindir}/gif2webp"