make-mod-scripts_1.0.bb 1.0 KB

1234567891011121314151617181920212223242526272829303132
  1. SUMMARY = "Build tools needed by external modules"
  2. LICENSE = "GPLv2"
  3. LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
  4. inherit kernel-arch
  5. inherit pkgconfig
  6. PACKAGE_ARCH = "${MACHINE_ARCH}"
  7. S = "${WORKDIR}"
  8. do_configure[depends] += "virtual/kernel:do_shared_workdir openssl-native:do_populate_sysroot"
  9. do_compile[depends] += "virtual/kernel:do_compile_kernelmodules"
  10. RDEPENDS_${PN}-dev = ""
  11. DEPENDS += "bc-native bison-native"
  12. DEPENDS += "gmp-native"
  13. EXTRA_OEMAKE = " HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" HOSTCPP="${BUILD_CPP}""
  14. EXTRA_OEMAKE += " HOSTCXX="${BUILD_CXX} ${BUILD_CXXFLAGS} ${BUILD_LDFLAGS}""
  15. # Build some host tools under work-shared. CC, LD, and AR are probably
  16. # not used, but this is the historical way of invoking "make scripts".
  17. #
  18. do_configure() {
  19. unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
  20. for t in prepare scripts_basic scripts; do
  21. oe_runmake CC="${KERNEL_CC}" LD="${KERNEL_LD}" AR="${KERNEL_AR}" \
  22. -C ${STAGING_KERNEL_DIR} O=${STAGING_KERNEL_BUILDDIR} $t
  23. done
  24. }