pointercal-xinput_0.0.bb 635 B

1234567891011121314151617181920
  1. SUMMARY = "Touchscreen calibration data from xinput-calibrator"
  2. LICENSE = "MIT"
  3. LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
  4. PR = "r7"
  5. SRC_URI = "file://pointercal.xinput"
  6. S = "${WORKDIR}"
  7. do_install() {
  8. # Only install file if it has a contents
  9. if [ -s ${S}/pointercal.xinput ] &&\
  10. [ ! -n "$(head -n1 ${S}/pointercal.xinput|grep "replace.*pointercal\.xinput")" ]; then
  11. install -d ${D}${sysconfdir}/
  12. install -m 0644 ${S}/pointercal.xinput ${D}${sysconfdir}/
  13. fi
  14. }
  15. PACKAGE_ARCH = "${MACHINE_ARCH}"
  16. CONFFILES_${PN} = "${sysconfdir}/pointercal.xinput"