piglit_git.bb 2.5 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465
  1. SUMMARY = "OpenGL driver testing framework"
  2. DESCRIPTION = "Piglit is an open-source test suite for OpenGL and OpenCL \
  3. implementations."
  4. LICENSE = "MIT & LGPLv2+ & GPLv3 & GPLv2+ & BSD-3-Clause"
  5. LIC_FILES_CHKSUM = "file://COPYING;md5=b2beded7103a3d8a442a2a0391d607b0"
  6. SRC_URI = "git://gitlab.freedesktop.org/mesa/piglit.git;protocol=https \
  7. file://0001-cmake-install-bash-completions-in-the-right-place.patch \
  8. file://0001-cmake-use-proper-WAYLAND_INCLUDE_DIRS-variable.patch \
  9. file://0001-Add-a-missing-include-for-htobe32-definition.patch \
  10. "
  11. UPSTREAM_CHECK_COMMITS = "1"
  12. SRCREV = "59e695c16fdcdd4ea4f16365f0e397a93cef7b80"
  13. # (when PV goes above 1.0 remove the trailing r)
  14. PV = "1.0+gitr${SRCPV}"
  15. S = "${WORKDIR}/git"
  16. X11_DEPS = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'virtual/libx11 libxrender libglu', '', d)}"
  17. X11_RDEPS = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'mesa-demos', '', d)}"
  18. DEPENDS = "libpng waffle libxkbcommon virtual/libgl python3-mako-native python3-numpy-native python3-six-native virtual/egl"
  19. inherit cmake pkgconfig python3native features_check bash-completion
  20. # depends on virtual/libgl
  21. REQUIRED_DISTRO_FEATURES += "opengl"
  22. # The built scripts go into the temporary directory according to tempfile
  23. # (typically /tmp) which can race if multiple builds happen on the same machine,
  24. # so tell it to use a directory in ${B} to avoid overwriting.
  25. export TEMP = "${B}/temp/"
  26. do_compile[dirs] =+ "${B}/temp/"
  27. PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}"
  28. PACKAGECONFIG[freeglut] = "-DPIGLIT_USE_GLUT=1,-DPIGLIT_USE_GLUT=0,freeglut,"
  29. PACKAGECONFIG[x11] = "-DPIGLIT_BUILD_GL_TESTS=ON,-DPIGLIT_BUILD_GL_TESTS=OFF,${X11_DEPS}, ${X11_RDEPS}"
  30. do_configure_prepend() {
  31. if [ "${@bb.utils.contains('PACKAGECONFIG', 'freeglut', 'yes', 'no', d)}" = "no" ]; then
  32. sed -i -e "/^#.*include <GL\/freeglut_ext.h>$/d" ${S}/src/piglit/glut_wrap.h
  33. sed -i -e "/^#.*include.*<GL\/glut.h>$/d" ${S}/src/piglit/glut_wrap.h
  34. fi
  35. }
  36. # Forcibly strip because Piglit is *huge*
  37. OECMAKE_TARGET_INSTALL = "install/strip"
  38. RDEPENDS_${PN} = "waffle waffle-bin python3 python3-mako python3-json \
  39. python3-misc \
  40. python3-unixadmin python3-xml python3-multiprocessing \
  41. python3-six python3-shell python3-io \
  42. python3-netserver bash \
  43. "
  44. INSANE_SKIP_${PN} += "dev-so already-stripped"
  45. # As nothing builds against Piglit we don't need to have anything in the
  46. # sysroot, especially when this is ~2GB of test suite
  47. SYSROOT_DIRS_remove = "${libdir}"
  48. # Can't be built with ccache
  49. CCACHE_DISABLE = "1"