libepoxy_1.5.4.bb 1.3 KB

123456789101112131415161718192021222324252627282930313233
  1. SUMMARY = "OpenGL function pointer management library"
  2. DESCRIPTION = "It hides the complexity of dlopen(), dlsym(), \
  3. glXGetProcAddress(), eglGetProcAddress(), etc. from the app developer, with \
  4. very little knowledge needed on their part. They get to read GL specs and \
  5. write code using undecorated function names like glCompileShader()."
  6. HOMEPAGE = "https://github.com/anholt/libepoxy/"
  7. SECTION = "libs"
  8. LICENSE = "MIT"
  9. LIC_FILES_CHKSUM = "file://COPYING;md5=58ef4c80d401e07bd9ee8b6b58cf464b"
  10. SRC_URI = "https://github.com/anholt/${BPN}/releases/download/${PV}/${BP}.tar.xz \
  11. file://0001-dispatch_common.h-define-also-EGL_NO_X11.patch \
  12. "
  13. SRC_URI[md5sum] = "00f47ad447321f9dc59f85bc1c9d0467"
  14. SRC_URI[sha256sum] = "0bd2cc681dfeffdef739cb29913f8c3caa47a88a451fd2bc6e606c02997289d2"
  15. UPSTREAM_CHECK_URI = "https://github.com/anholt/libepoxy/releases"
  16. inherit meson pkgconfig features_check
  17. REQUIRED_DISTRO_FEATURES = "opengl"
  18. PACKAGECONFIG[egl] = "-Degl=yes, -Degl=no, virtual/egl"
  19. PACKAGECONFIG[x11] = "-Dglx=yes, -Dglx=no -Dx11=false, virtual/libx11 virtual/libgl"
  20. PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)} egl"
  21. EXTRA_OEMESON += "-Dtests=false"
  22. PACKAGECONFIG_class-native = "egl x11"
  23. PACKAGECONFIG_class-nativesdk = "egl x11"
  24. BBCLASSEXTEND = "native nativesdk"