gconf_3.2.6.bb 2.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960
  1. SUMMARY = "GNOME configuration system"
  2. DESCRIPTION = "GConf is a system for storing application preferences. \
  3. It is intended for user preferences; not configuration of something like \
  4. Apache, or arbitrary data storage."
  5. SECTION = "x11/gnome"
  6. HOMEPAGE = "https://gitlab.gnome.org/Archive/gconf"
  7. LICENSE = "LGPLv2+"
  8. LIC_FILES_CHKSUM = "file://COPYING;md5=55ca817ccb7d5b5b66355690e9abc605"
  9. DEPENDS = "glib-2.0 dbus dbus-glib libxml2 intltool-native"
  10. inherit gnomebase gtk-doc gettext gobject-introspection gio-module-cache
  11. SRC_URI = "${GNOME_MIRROR}/GConf/${@gnome_verdir("${PV}")}/GConf-${PV}.tar.xz;name=archive \
  12. file://remove_plus_from_invalid_characters_list.patch \
  13. file://unable-connect-dbus.patch \
  14. file://create_config_directory.patch \
  15. file://python3.patch \
  16. "
  17. SRC_URI[archive.md5sum] = "2b16996d0e4b112856ee5c59130e822c"
  18. SRC_URI[archive.sha256sum] = "1912b91803ab09a5eed34d364bf09fe3a2a9c96751fde03a4e0cfa51a04d784c"
  19. S = "${WORKDIR}/GConf-${PV}"
  20. EXTRA_OECONF = "--enable-shared --disable-static \
  21. --disable-orbit --with-openldap=no --disable-gtk"
  22. PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'polkit', d)}"
  23. # We really don't want Polkit for native
  24. PACKAGECONFIG_class-native = ""
  25. PACKAGECONFIG[polkit] = "--enable-defaults-service,--disable-defaults-service,polkit"
  26. PACKAGECONFIG[debug] = "--enable-debug=yes, --enable-debug=minimum"
  27. do_install_append() {
  28. # this directory need to be created to avoid an Error 256 at gdm launch
  29. install -d ${D}${sysconfdir}/gconf/gconf.xml.system
  30. # this stuff is unusable
  31. rm -f ${D}${libdir}/GConf/*/*.*a
  32. rm -f ${D}${libdir}/gio/*/*.*a
  33. }
  34. do_install_append_class-native() {
  35. create_wrapper ${D}/${bindir}/gconftool-2 \
  36. GCONF_BACKEND_DIR=${STAGING_LIBDIR_NATIVE}/GConf/2
  37. }
  38. FILES_${PN} += "${libdir}/GConf/* \
  39. ${libdir}/gio/*/*.so \
  40. ${datadir}/polkit* \
  41. ${datadir}/dbus-1/services/*.service \
  42. ${datadir}/dbus-1/system-services/*.service \
  43. "
  44. RDEPENDS_${PN} = "python3-xml"
  45. FILES_${PN}-dev += "${datadir}/sgml/gconf/gconf-1.0.dtd"
  46. BBCLASSEXTEND = "native"