xinetd_2.3.15.4.bb 1.5 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647
  1. SUMMARY = "Socket-based service activation daemon"
  2. HOMEPAGE = "https://github.com/xinetd-org/xinetd"
  3. # xinetd is a BSD-like license
  4. # Apple and Gentoo say BSD here.
  5. LICENSE = "BSD"
  6. LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=55c5fdf02cfcca3fc9621b6f2ceae10f"
  7. UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>\d+(\.\d+)+)"
  8. SRC_URI = "git://github.com/openSUSE/xinetd.git;protocol=https \
  9. file://xinetd.init \
  10. file://xinetd.default \
  11. file://xinetd.service \
  12. "
  13. SRCREV = "6a4af7786630ce48747d9687e2f18f45ea6684c4"
  14. S = "${WORKDIR}/git"
  15. inherit autotools update-rc.d systemd pkgconfig
  16. SYSTEMD_SERVICE_${PN} = "xinetd.service"
  17. INITSCRIPT_NAME = "xinetd"
  18. INITSCRIPT_PARAMS = "defaults"
  19. PACKAGECONFIG ??= "tcp-wrappers"
  20. PACKAGECONFIG[tcp-wrappers] = "--with-libwrap,,tcp-wrappers"
  21. CONFFILES_${PN} = "${sysconfdir}/xinetd.conf"
  22. do_install_append() {
  23. install -d "${D}${sysconfdir}/init.d"
  24. install -d "${D}${sysconfdir}/default"
  25. install -m 755 "${WORKDIR}/xinetd.init" "${D}${sysconfdir}/init.d/xinetd"
  26. install -m 644 "${WORKDIR}/xinetd.default" "${D}${sysconfdir}/default/xinetd"
  27. # Install systemd unit files
  28. install -d ${D}${systemd_unitdir}/system
  29. install -m 0644 ${WORKDIR}/xinetd.service ${D}${systemd_unitdir}/system
  30. sed -i -e 's,@BASE_BINDIR@,${base_bindir},g' \
  31. -e 's,@SBINDIR@,${sbindir},g' \
  32. ${D}${systemd_unitdir}/system/xinetd.service
  33. }
  34. RDEPENDS_${PN} += "perl"