which_2.21.bb 1.2 KB

1234567891011121314151617181920212223242526272829303132333435
  1. SUMMARY = "Displays the full path of shell commands"
  2. DESCRIPTION = "Which is a utility that prints out the full path of the \
  3. executables that bash(1) would execute when the passed \
  4. program names would have been entered on the shell prompt. \
  5. It does this by using the exact same algorithm as bash."
  6. SECTION = "libs"
  7. HOMEPAGE = "https://carlowood.github.io/which/"
  8. LICENSE = "GPLv3+"
  9. LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504\
  10. file://which.c;beginline=1;endline=17;md5=a9963693af2272e7a8df6f231164e7a2"
  11. DEPENDS = "cwautomacros-native"
  12. inherit autotools texinfo update-alternatives
  13. PR = "r3"
  14. EXTRA_OECONF = "--disable-iberty"
  15. SRC_URI = "${GNU_MIRROR}/which/which-${PV}.tar.gz \
  16. file://automake.patch \
  17. "
  18. SRC_URI[md5sum] = "097ff1a324ae02e0a3b0369f07a7544a"
  19. SRC_URI[sha256sum] = "f4a245b94124b377d8b49646bf421f9155d36aa7614b6ebf83705d3ffc76eaad"
  20. do_configure_prepend() {
  21. sed -i -e 's%@ACLOCAL_CWFLAGS@%-I ${STAGING_DIR_NATIVE}/usr/share/cwautomacros/m4%g' ${S}/Makefile.am ${S}/tilde/Makefile.am
  22. }
  23. ALTERNATIVE_${PN} = "which"
  24. ALTERNATIVE_PRIORITY = "100"
  25. ALTERNATIVE_${PN}-doc = "which.1"
  26. ALTERNATIVE_LINK_NAME[which.1] = "${mandir}/man1/which.1"