rpcsvc-proto.bb 1.1 KB

1234567891011121314151617181920212223242526272829303132333435363738394041
  1. # Copyright (C) 2018 Khem Raj <raj.khem@gmail.com>
  2. # Released under the MIT license (see COPYING.MIT for the terms)
  3. SUMMARY = "rpcsvc protocol definitions from glibc"
  4. DESCRIPTION = "This package contains rpcsvc proto.x files from glibc, which are\
  5. missing in libtirpc. Additional it contains rpcgen, which is needed\
  6. to create header files and sources from protocol files.\
  7. This package is only needed, if glibc is installed without the\
  8. deprecated sunrpc functionality and libtirpc should replace it."
  9. HOMEPAGE = "https://github.com/thkukuk/rpcsvc-proto"
  10. LICENSE = "BSD-3-Clause"
  11. LIC_FILES_CHKSUM = "file://COPYING;md5=0daaf958d5531ab86169ec6e275e1517"
  12. SECTION = "libs"
  13. DEPENDS += "rpcsvc-proto-native"
  14. PV = "1.4.2"
  15. SRCREV = "6f54e54455c073d08a56ea627c6cd2355a40eb53"
  16. SRC_URI = "git://github.com/thkukuk/${BPN} \
  17. file://0001-Use-cross-compiled-rpcgen.patch \
  18. "
  19. S = "${WORKDIR}/git"
  20. inherit autotools gettext
  21. EXTRA_OEMAKE_class-native = " -C rpcgen"
  22. do_configure_prepend() {
  23. touch ${S}/ABOUT-NLS
  24. }
  25. do_install_append() {
  26. # They come from quota recipe
  27. rm -rf ${D}${includedir}/rpcsvc/rquota.[hx]
  28. }
  29. BBCLASSEXTEND += "native nativesdk"