pbzip2_1.1.13.bb 1.2 KB

12345678910111213141516171819202122232425262728293031
  1. SUMMARY = "PBZIP2 is a parallel implementation of bzip2"
  2. DESCRIPTION = "PBZIP2 is a parallel implementation of the bzip2 block-sorting \
  3. file compressor that uses pthreads and achieves near-linear speedup on SMP \
  4. machines. The output of this version is fully compatible with bzip2 v1.0.2 or \
  5. newer (ie: anything compressed with pbzip2 can be decompressed with bzip2)."
  6. HOMEPAGE = "https://launchpad.net/pbzip2/"
  7. SECTION = "console/utils"
  8. LICENSE = "bzip2-1.0.6"
  9. LIC_FILES_CHKSUM = "file://COPYING;md5=398b8832c6f840cfebd20ab2be6a3743"
  10. DEPENDS = "bzip2"
  11. DEPENDS_append_class-native = " bzip2-replacement-native"
  12. SRC_URI = "https://launchpad.net/${BPN}/1.1/${PV}/+download/${BP}.tar.gz \
  13. file://0001-pbzip2-Fix-invalid-suffix-on-literal-C-11-warning.patch \
  14. "
  15. SRC_URI[md5sum] = "4cb87da2dba05540afce162f34b3a9a6"
  16. SRC_URI[sha256sum] = "8fd13eaaa266f7ee91f85c1ea97c86d9c9cc985969db9059cdebcb1e1b7bdbe6"
  17. UPSTREAM_CHECK_URI = "https://launchpad.net/pbzip2/+milestones"
  18. UPSTREAM_CHECK_REGEX = "pbzip2 (?P<pver>\d+(\.\d+)+)"
  19. EXTRA_OEMAKE = "CXX='${CXX} ${CXXFLAGS}' LDFLAGS='${LDFLAGS}'"
  20. do_install() {
  21. install -d ${D}${bindir}
  22. install -m 0755 pbzip2 ${D}${bindir}/
  23. }
  24. BBCLASSEXTEND = "native nativesdk"