packagegroup-core-base-utils.bb 1.3 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061
  1. #
  2. # Copyright (C) 2019 Konsulko Group
  3. #
  4. SUMMARY = "Full-featured set of base utils"
  5. DESCRIPTION = "Package group bringing in packages needed to provide much of the base utils type functionality found in busybox"
  6. PACKAGE_ARCH = "${MACHINE_ARCH}"
  7. inherit packagegroup
  8. VIRTUAL-RUNTIME_vim ?= "vim-tiny"
  9. PACKAGE_ARCH = "${MACHINE_ARCH}"
  10. RDEPENDS_${PN} = "\
  11. base-passwd \
  12. bash \
  13. bind-utils \
  14. bzip2 \
  15. coreutils \
  16. cpio \
  17. ${@bb.utils.contains("DISTRO_FEATURES", "systemd", "", "debianutils-run-parts", d)} \
  18. dhcpcd \
  19. ${@bb.utils.contains("DISTRO_FEATURES", "systemd", "", "kea", d)} \
  20. diffutils \
  21. ${@bb.utils.contains("DISTRO_FEATURES", "systemd", "", "dpkg-start-stop", d)} \
  22. e2fsprogs \
  23. ed \
  24. file \
  25. findutils \
  26. gawk \
  27. grep \
  28. gzip \
  29. ${@bb.utils.contains("DISTRO_FEATURES", "systemd", "", "ifupdown", d)} \
  30. inetutils \
  31. inetutils-ping \
  32. inetutils-telnet \
  33. inetutils-tftp \
  34. inetutils-traceroute \
  35. iproute2 \
  36. ${@bb.utils.contains("MACHINE_FEATURES", "keyboard", "kbd", "", d)} \
  37. kmod \
  38. less \
  39. ncurses-tools \
  40. net-tools \
  41. parted \
  42. patch \
  43. procps \
  44. psmisc \
  45. sed \
  46. shadow-base \
  47. tar \
  48. time \
  49. unzip \
  50. util-linux \
  51. ${VIRTUAL-RUNTIME_vim} \
  52. wget \
  53. which \
  54. xz \
  55. "