libnewt_0.52.21.bb 1.7 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758
  1. SUMMARY = "A library for text mode user interfaces"
  2. DESCRIPTION = "Newt is a programming library for color text mode, widget based user \
  3. interfaces. Newt can be used to add stacked windows, entry widgets, \
  4. checkboxes, radio buttons, labels, plain text fields, scrollbars, \
  5. etc., to text mode user interfaces. This package also contains the \
  6. shared library needed by programs built with newt, as well as a \
  7. /usr/bin/dialog replacement called whiptail. Newt is based on the \
  8. slang library."
  9. HOMEPAGE = "https://releases.pagure.org/newt/"
  10. SECTION = "libs"
  11. LICENSE = "LGPLv2"
  12. LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2"
  13. # slang needs to be >= 2.2
  14. DEPENDS = "slang popt python3"
  15. SRC_URI = "https://releases.pagure.org/newt/newt-${PV}.tar.gz \
  16. file://cross_ar.patch \
  17. file://Makefile.in-Add-tinfo-library-to-the-linking-librari.patch \
  18. file://0001-detect-gold-as-GNU-linker-too.patch \
  19. file://0002-don-t-ignore-CFLAGS-when-building-snack.patch \
  20. "
  21. SRC_URI[md5sum] = "a0a5fd6b53bb167a65e15996b249ebb5"
  22. SRC_URI[sha256sum] = "265eb46b55d7eaeb887fca7a1d51fe115658882dfe148164b6c49fccac5abb31"
  23. S = "${WORKDIR}/newt-${PV}"
  24. inherit autotools-brokensep python3native python3-dir
  25. EXTRA_OECONF = "--without-tcl --with-python"
  26. EXTRA_OEMAKE += "PYTHONVERS=${PYTHON_DIR}"
  27. CLEANBROKEN = "1"
  28. export CPPFLAGS
  29. PACKAGES_prepend = "whiptail ${PN}-python "
  30. RDEPENDS_${PN}-python += "python3-core"
  31. FILES_${PN}-python = "${PYTHON_SITEPACKAGES_DIR}/*"
  32. do_configure_prepend() {
  33. sh autogen.sh
  34. }
  35. do_compile_prepend() {
  36. # Make sure the recompile is OK
  37. rm -f ${B}/.depend
  38. }
  39. FILES_whiptail = "${bindir}/whiptail"
  40. BBCLASSEXTEND = "native nativesdk"