acpica_20200925.bb 1.5 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849
  1. SUMMARY = "ACPICA tools for the development and debug of ACPI tables"
  2. DESCRIPTION = "The ACPI Component Architecture (ACPICA) project provides an \
  3. OS-independent reference implementation of the Advanced Configuration and \
  4. Power Interface Specification (ACPI). ACPICA code contains those portions of \
  5. ACPI meant to be directly integrated into the host OS as a kernel-resident \
  6. subsystem, and a small set of tools to assist in developing and debugging \
  7. ACPI tables."
  8. HOMEPAGE = "http://www.acpica.org/"
  9. SECTION = "console/tools"
  10. LICENSE = "Intel | BSD | GPLv2"
  11. LIC_FILES_CHKSUM = "file://source/compiler/aslcompile.c;beginline=7;endline=150;md5=6adbcb81e9ee6ae50c569b94fe12f7c5"
  12. COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux"
  13. DEPENDS = "m4-native flex-native bison-native"
  14. SRC_URI = "https://acpica.org/sites/acpica/files/acpica-unix-${PV}.tar.gz"
  15. SRC_URI[sha256sum] = "d44388e21e3d2e47c6d39e9c897935d3f775f04fec76271dcba072c74f834589"
  16. UPSTREAM_CHECK_URI = "https://acpica.org/downloads"
  17. S = "${WORKDIR}/acpica-unix-${PV}"
  18. inherit update-alternatives
  19. ALTERNATIVE_PRIORITY = "100"
  20. ALTERNATIVE_${PN} = "acpixtract acpidump"
  21. EXTRA_OEMAKE = "CC='${CC}' \
  22. OPT_CFLAGS=-Wall \
  23. DESTDIR=${D} \
  24. PREFIX=${prefix} \
  25. INSTALLDIR=${bindir} \
  26. INSTALLFLAGS= \
  27. "
  28. do_install() {
  29. oe_runmake install
  30. }
  31. # iasl*.bb is a subset of this recipe, so RREPLACE it
  32. PROVIDES = "iasl"
  33. RPROVIDES_${PN} += "iasl"
  34. RREPLACES_${PN} += "iasl"
  35. RCONFLICTS_${PN} += "iasl"
  36. BBCLASSEXTEND = "native"