unfs3_git.bb 1.6 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243
  1. SUMMARY = "Userspace NFS server v3 protocol"
  2. DESCRIPTION = "UNFS3 is a user-space implementation of the NFSv3 server \
  3. specification. It provides a daemon for the MOUNT and NFS protocols, which \
  4. are used by NFS clients for accessing files on the server."
  5. SECTION = "console/network"
  6. LICENSE = "unfs3"
  7. LIC_FILES_CHKSUM = "file://LICENSE;md5=9475885294e17c0cc0067820d042792e"
  8. DEPENDS = "flex-native bison-native flex"
  9. DEPENDS += "libtirpc"
  10. DEPENDS_append_class-nativesdk = " flex-nativesdk"
  11. ASNEEDED = ""
  12. S = "${WORKDIR}/git"
  13. SRC_URI = "git://github.com/unfs3/unfs3.git;protocol=https \
  14. file://unfs3_parallel_build.patch \
  15. file://alternate_rpc_ports.patch \
  16. file://fix_pid_race_parent_writes_child_pid.patch \
  17. file://fix_compile_warning.patch \
  18. file://rename_fh_cache.patch \
  19. file://relative_max_socket_path_len.patch \
  20. file://tcp_no_delay.patch \
  21. file://0001-daemon.c-Libtirpc-porting-fixes.patch \
  22. file://0001-attr-fix-utime-for-symlink.patch \
  23. file://0001-Add-listen-action-for-a-tcp-socket.patch \
  24. "
  25. SRCREV = "c12a5c69a8d59be6916cbd0e0f41c159f1962425"
  26. UPSTREAM_CHECK_GITTAGREGEX = "unfs3\-(?P<pver>.+)"
  27. PV = "0.9.22+${SRCPV}"
  28. BBCLASSEXTEND = "native nativesdk"
  29. inherit autotools
  30. EXTRA_OECONF_append_class-native = " --sbindir=${bindir}"
  31. CFLAGS_append = " -I${STAGING_INCDIR}/tirpc"
  32. LDFLAGS_append = " -ltirpc"
  33. # Turn off these header detects else the inode search
  34. # will walk entire file systems and this is a real problem
  35. # if you have 2 TB of files to walk in your file system
  36. CACHED_CONFIGUREVARS = "ac_cv_header_mntent_h=no ac_cv_header_sys_mnttab_h=no"