libxml-perl_0.08.bb 1.1 KB

123456789101112131415161718192021222324252627282930
  1. DESCRIPTION = "libxml-perl is a collection of smaller Perl modules, scripts, and \
  2. documents for working with XML in Perl. libxml-perl software \
  3. works in combination with XML::Parser, PerlSAX, XML::DOM, \
  4. XML::Grove and others."
  5. HOMEPAGE = "http://search.cpan.org/dist/libxml-perl/"
  6. SUMMARY = "Collection of Perl modules for working with XML"
  7. SECTION = "libs"
  8. LICENSE = "Artistic-1.0 | GPL-1.0+"
  9. PR = "r3"
  10. LIC_FILES_CHKSUM = "file://README;beginline=33;endline=35;md5=1705549eef7577a3d6ba71123a1f0ce8"
  11. DEPENDS += "libxml-parser-perl"
  12. SRC_URI = "http://www.cpan.org/modules/by-module/XML/${BPN}-${PV}.tar.gz"
  13. SRC_URI[md5sum] = "0ed5fbdda53d1301ddaed88db10503bb"
  14. SRC_URI[sha256sum] = "4571059b7b5d48b7ce52b01389e95d798bf5cf2020523c153ff27b498153c9cb"
  15. EXTRA_CPANFLAGS = "EXPATLIBPATH=${STAGING_LIBDIR} EXPATINCPATH=${STAGING_INCDIR}"
  16. inherit cpan ptest-perl
  17. do_compile() {
  18. export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')"
  19. cpan_do_compile
  20. }
  21. RDEPENDS_${PN} += "perl-module-carp perl-module-overload perl-module-universal perl-module-io-handle"
  22. RDEPENDS_${PN}-ptest += "libxml-parser-perl perl-module-file-glob"