liburi-perl_1.74.bb 1.4 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950
  1. SUMMARY = "Perl module to manipulate and access URI strings"
  2. DESCRIPTION = "This package contains the URI.pm module with friends. \
  3. The module implements the URI class. URI objects can be used to access \
  4. and manipulate the various components that make up these strings."
  5. HOMEPAGE = "http://search.cpan.org/dist/URI/"
  6. SECTION = "libs"
  7. LICENSE = "Artistic-1.0 | GPL-1.0+"
  8. LIC_FILES_CHKSUM = "file://LICENSE;md5=c453e94fae672800f83bc1bd7a38b53f"
  9. DEPENDS += "perl"
  10. SRC_URI = "http://www.cpan.org/authors/id/E/ET/ETHER/URI-${PV}.tar.gz"
  11. SRC_URI[md5sum] = "892f7183b178af40f205ba37128225db"
  12. SRC_URI[sha256sum] = "a9c254f45f89cb1dd946b689dfe433095404532a4543bdaab0b71ce0fdcdd53d"
  13. S = "${WORKDIR}/URI-${PV}"
  14. EXTRA_CPANFLAGS = "EXPATLIBPATH=${STAGING_LIBDIR} EXPATINCPATH=${STAGING_INCDIR}"
  15. inherit cpan ptest-perl
  16. do_compile() {
  17. export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')"
  18. cpan_do_compile
  19. }
  20. do_install_prepend() {
  21. # these tests require "-T" (taint) command line option
  22. rm -rf ${B}/t/cwd.t
  23. rm -rf ${B}/t/file.t
  24. }
  25. RDEPENDS_${PN} += "perl-module-integer perl-module-mime-base64"
  26. RDEPENDS_${PN}-ptest += " \
  27. libtest-needs-perl \
  28. perl-module-test-more \
  29. perl-module-test \
  30. perl-module-utf8 \
  31. perl-module-extutils-makemaker \
  32. perl-module-net-domain \
  33. perl-module-encode \
  34. perl-module-extutils-mm-unix \
  35. perl-module-file-spec-functions \
  36. perl-module-perlio \
  37. "
  38. BBCLASSEXTEND = "native"