libmodule-build-perl_0.4231.bb 3.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123
  1. SUMMARY = "Module::Build - Build and install Perl modules"
  2. DESCRIPTION = "Many Perl distributions use a Build.PL file instead of a \
  3. Makefile.PL file to drive distribution configuration, build, test and \
  4. installation. Traditionally, Build.PL uses Module::Build as the underlying \
  5. build system. This module provides a simple, lightweight, drop-in replacement. \
  6. Whereas Module::Build has over 6,700 lines of code; this module has less than \
  7. 120, yet supports the features needed by most distributions."
  8. SECTION = "libs"
  9. HOMEPAGE = "https://metacpan.org/release/Module-Build"
  10. LICENSE = "Artistic-1.0 | GPL-1.0+"
  11. LIC_FILES_CHKSUM = "file://README;beginline=949;endline=954;md5=624c06db56a2af4d70cf9edc29fcae1b"
  12. SRC_URI = "${CPAN_MIRROR}/authors/id/L/LE/LEONT/Module-Build-${PV}.tar.gz \
  13. file://run-ptest \
  14. "
  15. SRC_URI[md5sum] = "066b193e461d7dfe1eca17a139353001"
  16. SRC_URI[sha256sum] = "7e0f4c692c1740c1ac84ea14d7ea3d8bc798b2fb26c09877229e04f430b2b717"
  17. S = "${WORKDIR}/Module-Build-${PV}"
  18. inherit cpan_build ptest-perl
  19. # From:
  20. # https://github.com/rehsack/meta-cpan/blob/master/recipes-devel/module-build-perl/module-build-perl_0.4216.bb
  21. #
  22. do_patch_module_build () {
  23. cd ${S}
  24. sed -i -e 's,my $interpreter = $self->{properties}{perl};,my $interpreter = "${bindir}/perl";,g' lib/Module/Build/Base.pm
  25. }
  26. do_patch[postfuncs] += "do_patch_module_build"
  27. EXTRA_CPAN_BUILD_FLAGS = "--create_packlist=0"
  28. do_install_append () {
  29. rm -rf ${D}${docdir}/perl/html
  30. }
  31. do_install_ptest() {
  32. cp -r ${B}/inc ${D}${PTEST_PATH}
  33. cp -r ${B}/blib ${D}${PTEST_PATH}
  34. cp -r ${B}/_build ${D}${PTEST_PATH}
  35. cp -r ${B}/lib ${D}${PTEST_PATH}
  36. chown -R root:root ${D}${PTEST_PATH}
  37. sed -i -e "s,'perl' => .*,'perl' => '/usr/bin/perl'\,,g" \
  38. -e "s,${STAGING_BINDIR_NATIVE}/perl-native/\.\.,${bindir}/,g" \
  39. -e "s,${S},,g" \
  40. -e "s,${D},,g" \
  41. ${D}${PTEST_PATH}/_build/build_params \
  42. ${D}${PTEST_PATH}/_build/runtime_params
  43. rm -rf ${D}${PTEST_PATH}/blib/libhtml/site/lib/Module/
  44. rm -rf ${D}${PTEST_PATH}/_build/magicnum
  45. }
  46. RDEPENDS_${PN} += " \
  47. perl-module-carp \
  48. perl-module-cpan \
  49. perl-module-config \
  50. perl-module-cwd \
  51. perl-module-data-dumper \
  52. perl-module-encode \
  53. perl-module-extutils-cbuilder \
  54. perl-module-extutils-command \
  55. perl-module-extutils-install \
  56. perl-module-extutils-installed \
  57. perl-module-extutils-mkbootstrap \
  58. perl-module-extutils-packlist \
  59. perl-module-extutils-parsexs \
  60. perl-module-file-basename \
  61. perl-module-file-compare \
  62. perl-module-file-copy \
  63. perl-module-file-find \
  64. perl-module-file-glob \
  65. perl-module-file-path \
  66. perl-module-file-spec \
  67. perl-module-file-spec-functions \
  68. perl-module-getopt-long \
  69. perl-module-metadata \
  70. perl-module-perl-ostype \
  71. perl-module-pod-man \
  72. perl-module-tap-harness \
  73. perl-module-text-abbrev \
  74. perl-module-text-parsewords \
  75. perl-module-utf8 \
  76. "
  77. RDEPENDS_${PN}-ptest += " \
  78. packagegroup-core-buildessential \
  79. perl-dev \
  80. perl-module-blib \
  81. perl-module-extutils-command-mm \
  82. perl-module-file-temp \
  83. perl-module-lib \
  84. perl-module-perlio \
  85. perl-module-perlio-encoding \
  86. perl-module-pod-text \
  87. perl-module-tap-harness-env \
  88. perl-module-tap-parser \
  89. perl-module-tap-parser-scheduler \
  90. perl-module-test-harness \
  91. perl-module-test-more \
  92. "
  93. RPROVIDES_${PN} += "\
  94. libmodule-build-base-perl \
  95. libmodule-build-compat-perl \
  96. libmodule-build-config-perl \
  97. libmodule-build-cookbook-perl \
  98. libmodule-build-dumper-perl \
  99. libmodule-build-notes-perl \
  100. libmodule-build-ppmaker-perl \
  101. libmodule-build-platform-default-perl \
  102. libmodule-build-platform-unix-perl \
  103. libmodule-build-podparser-perl \
  104. "
  105. # t/xs.t RDEPENDS on "EXTERN.h" provided by perl-dev
  106. INSANE_SKIP_${PN}-ptest = "dev-deps"
  107. BBCLASSEXTEND = "native"