liberror-perl_0.17029.bb 1.3 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647
  1. SUMMARY = "Error - Error/exception handling in an OO-ish way"
  2. DESCRIPTION = "The Error package provides two interfaces. Firstly \
  3. Error provides a procedural interface to exception handling. \
  4. Secondly Error is a base class for errors/exceptions that can \
  5. either be thrown, for subsequent catch, or can simply be recorded."
  6. HOMEPAGE = "https://github.com/shlomif/perl-error.pm"
  7. SECTION = "libs"
  8. LICENSE = "Artistic-1.0 | GPL-1.0+"
  9. LIC_FILES_CHKSUM = "file://LICENSE;md5=8f3499d09ee74a050c0319391ff9d100"
  10. DEPENDS += "perl"
  11. RDEPENDS_${PN} += " \
  12. perl-module-carp \
  13. perl-module-exporter \
  14. perl-module-scalar-util \
  15. perl-module-overload \
  16. perl-module-strict \
  17. perl-module-vars \
  18. perl-module-warnings \
  19. "
  20. RDEPENDS_${PN}-ptest += " \
  21. perl-module-base \
  22. perl-module-file-spec \
  23. perl-module-io-handle \
  24. perl-module-ipc-open3 \
  25. perl-module-lib \
  26. perl-module-test-more \
  27. "
  28. SRC_URI = "http://cpan.metacpan.org/authors/id/S/SH/SHLOMIF/Error-${PV}.tar.gz"
  29. SRC_URI[md5sum] = "6732b1c6207e4a9a3e2987c88368039a"
  30. SRC_URI[sha256sum] = "1a23f7913032aed6d4b68321373a3899ca66590f4727391a091ec19c95bf7adc"
  31. S = "${WORKDIR}/Error-${PV}"
  32. inherit cpan ptest-perl
  33. do_install_prepend() {
  34. # test requires "-T" (taint) command line option
  35. rm -rf ${B}/t/pod-coverage.t
  36. }
  37. BBCLASSEXTEND = "native"