opkg-arch-config_1.0.bb 786 B

1234567891011121314151617181920212223242526272829303132333435
  1. SUMMARY = "Architecture-dependent configuration for opkg"
  2. HOMEPAGE = "http://code.google.com/p/opkg/"
  3. LICENSE = "MIT"
  4. PACKAGE_ARCH = "${MACHINE_ARCH}"
  5. PR = "r1"
  6. S = "${WORKDIR}"
  7. do_compile() {
  8. mkdir -p ${S}/${sysconfdir}/opkg/
  9. archconf=${S}/${sysconfdir}/opkg/arch.conf
  10. rm -f $archconf
  11. ipkgarchs="${ALL_MULTILIB_PACKAGE_ARCHS}"
  12. priority=1
  13. for arch in $ipkgarchs; do
  14. echo "arch $arch $priority" >> $archconf
  15. priority=$(expr $priority + 5)
  16. done
  17. }
  18. do_install () {
  19. install -d ${D}${sysconfdir}/opkg
  20. install -m 0644 ${S}/${sysconfdir}/opkg/* ${D}${sysconfdir}/opkg/
  21. }
  22. FILES_${PN} = "${sysconfdir}/opkg/ "
  23. CONFFILES_${PN} += "${sysconfdir}/opkg/arch.conf"
  24. RREPLACES_${PN} = "opkg-config-base"
  25. RCONFLICTS_${PN} = "opkg-config-base"
  26. RPROVIDES_${PN} = "opkg-config-base"