opkg-utils_0.4.3.bb 2.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566
  1. SUMMARY = "Additional utilities for the opkg package manager"
  2. SUMMARY_update-alternatives-opkg = "Utility for managing the alternatives system"
  3. SECTION = "base"
  4. HOMEPAGE = "http://git.yoctoproject.org/cgit/cgit.cgi/opkg-utils"
  5. LICENSE = "GPLv2+"
  6. LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
  7. file://opkg.py;beginline=2;endline=18;md5=ffa11ff3c15eb31c6a7ceaa00cc9f986"
  8. PROVIDES += "${@bb.utils.contains('PACKAGECONFIG', 'update-alternatives', 'virtual/update-alternatives', '', d)}"
  9. SRC_URI = "http://git.yoctoproject.org/cgit/cgit.cgi/${BPN}/snapshot/${BPN}-${PV}.tar.gz \
  10. file://0001-update-alternatives-correctly-match-priority.patch \
  11. "
  12. UPSTREAM_CHECK_URI = "http://git.yoctoproject.org/cgit/cgit.cgi/opkg-utils/refs/"
  13. SRC_URI[md5sum] = "7bbadb3c381f3ea935b21d3bb8cc4671"
  14. SRC_URI[sha256sum] = "046517600fb0aed6c4645edefe02281f4fa2f1c02f71596152d93172452c0b01"
  15. TARGET_CC_ARCH += "${LDFLAGS}"
  16. RDEPENDS_${PN} += "bash"
  17. inherit perlnative
  18. # For native builds we use the host Python
  19. PYTHONRDEPS = "python3 python3-shell python3-io python3-math python3-crypt python3-logging python3-fcntl python3-pickle python3-compression python3-stringold"
  20. PYTHONRDEPS_class-native = ""
  21. PACKAGECONFIG = "python update-alternatives"
  22. PACKAGECONFIG[python] = ",,,${PYTHONRDEPS}"
  23. PACKAGECONFIG[update-alternatives] = ",,,"
  24. do_install() {
  25. oe_runmake PREFIX=${prefix} DESTDIR=${D} install
  26. if ! ${@bb.utils.contains('PACKAGECONFIG', 'update-alternatives', 'true', 'false', d)}; then
  27. rm -f "${D}${bindir}/update-alternatives"
  28. fi
  29. }
  30. do_install_append_class-target() {
  31. if ! ${@bb.utils.contains('PACKAGECONFIG', 'python', 'true', 'false', d)}; then
  32. grep -lZ "/usr/bin/env.*python" ${D}${bindir}/* | xargs -0 rm
  33. fi
  34. if [ -e "${D}${bindir}/update-alternatives" ]; then
  35. sed -i ${D}${bindir}/update-alternatives -e 's,/usr/bin,${bindir},g; s,/usr/lib,${nonarch_libdir},g'
  36. fi
  37. }
  38. # These are empty and will pull python3-dev into images where it wouldn't
  39. # have been otherwise, so don't generate them.
  40. PACKAGES_remove = "${PN}-dev ${PN}-staticdev"
  41. PACKAGES =+ "update-alternatives-opkg"
  42. FILES_update-alternatives-opkg = "${bindir}/update-alternatives"
  43. RPROVIDES_update-alternatives-opkg = "update-alternatives update-alternatives-cworth"
  44. RREPLACES_update-alternatives-opkg = "update-alternatives-cworth"
  45. RCONFLICTS_update-alternatives-opkg = "update-alternatives-cworth"
  46. pkg_postrm_update-alternatives-opkg() {
  47. rm -rf $D${nonarch_libdir}/opkg/alternatives
  48. rmdir $D${nonarch_libdir}/opkg || true
  49. }
  50. BBCLASSEXTEND = "native nativesdk"
  51. CLEANBROKEN = "1"