flex_2.6.4.bb 3.0 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374757677
  1. SUMMARY = "Flex (The Fast Lexical Analyzer)"
  2. DESCRIPTION = "Flex is a fast lexical analyser generator. Flex is a tool for generating programs that recognize \
  3. lexical patterns in text."
  4. HOMEPAGE = "http://sourceforge.net/projects/flex/"
  5. SECTION = "devel"
  6. LICENSE = "BSD-2-Clause"
  7. DEPENDS = "${@bb.utils.contains('PTEST_ENABLED', '1', 'bison-native flex-native', '', d)}"
  8. BBCLASSEXTEND = "native nativesdk"
  9. LIC_FILES_CHKSUM = "file://COPYING;md5=e4742cf92e89040b39486a6219b68067"
  10. SRC_URI = "https://github.com/westes/flex/releases/download/v${PV}/flex-${PV}.tar.gz \
  11. file://run-ptest \
  12. file://0001-tests-add-a-target-for-building-tests-without-runnin.patch \
  13. ${@bb.utils.contains('PTEST_ENABLED', '1', '', 'file://disable-tests.patch', d)} \
  14. file://0001-build-AC_USE_SYSTEM_EXTENSIONS-in-configure.ac.patch \
  15. file://check-funcs.patch \
  16. "
  17. SRC_URI[md5sum] = "2882e3179748cc9f9c23ec593d6adc8d"
  18. SRC_URI[sha256sum] = "e87aae032bf07c26f85ac0ed3250998c37621d95f8bd748b31f15b33c45ee995"
  19. # Flex has moved to github from 2.6.1 onwards
  20. UPSTREAM_CHECK_URI = "https://github.com/westes/flex/releases"
  21. UPSTREAM_CHECK_REGEX = "flex-(?P<pver>\d+(\.\d+)+)\.tar"
  22. inherit autotools gettext texinfo ptest
  23. M4 = "${bindir}/m4"
  24. M4_class-native = "${STAGING_BINDIR_NATIVE}/m4"
  25. EXTRA_OECONF += "ac_cv_path_M4=${M4} ac_cv_func_reallocarray=no"
  26. EXTRA_OEMAKE += "m4=${STAGING_BINDIR_NATIVE}/m4"
  27. EXTRA_OEMAKE += "${@bb.utils.contains('PTEST_ENABLED', '1', 'FLEX=${STAGING_BINDIR_NATIVE}/flex', '', d)}"
  28. do_install_append_class-native() {
  29. create_wrapper ${D}/${bindir}/flex M4=${M4}
  30. }
  31. do_install_append_class-nativesdk() {
  32. create_wrapper ${D}/${bindir}/flex M4=${M4}
  33. }
  34. PACKAGES =+ "${PN}-libfl"
  35. FILES_${PN}-libfl = "${libdir}/libfl.so.* ${libdir}/libfl_pic.so.*"
  36. RDEPENDS_${PN} += "m4"
  37. RDEPENDS_${PN}-ptest += "bash gawk make"
  38. do_compile_ptest() {
  39. oe_runmake -C ${B}/tests -f ${B}/tests/Makefile top_builddir=${B} INCLUDES=-I${S}/src buildtests
  40. }
  41. do_install_ptest() {
  42. mkdir -p ${D}${PTEST_PATH}/build-aux/
  43. cp ${S}/build-aux/test-driver ${D}${PTEST_PATH}/build-aux/
  44. cp -r ${S}/tests/* ${D}${PTEST_PATH}
  45. cp -r ${B}/tests/* ${D}${PTEST_PATH}
  46. sed -e 's,--sysroot=${STAGING_DIR_TARGET},,g' \
  47. -e 's|${DEBUG_PREFIX_MAP}||g' \
  48. -e 's:${HOSTTOOLS_DIR}/::g' \
  49. -e 's:${RECIPE_SYSROOT_NATIVE}::g' \
  50. -e 's:${BASE_WORKDIR}/${MULTIMACH_TARGET_SYS}::g' \-e 's/^Makefile:/_Makefile:/' \
  51. -e 's/^srcdir = \(.*\)/srcdir = ./' -e 's/^top_srcdir = \(.*\)/top_srcdir = ./' \
  52. -e 's/^builddir = \(.*\)/builddir = ./' -e 's/^top_builddir = \(.*\)/top_builddir = ./' \
  53. -e 's:${UNINATIVE_LOADER}:${base_bindir}/false:g' \
  54. -i ${D}${PTEST_PATH}/Makefile
  55. }
  56. # The uninative loader is different on i386 & x86_64 hosts. Since it is only
  57. # being replaced with /bin/false anyway, it doesn't need to be part of the task
  58. # hash
  59. do_install_ptest[vardepsexclude] += "UNINATIVE_LOADER"
  60. # Not Apache Flex, or Adobe Flex, or IBM Flex.
  61. CVE_PRODUCT = "flex_project:flex"