docbook-xml-dtd4_4.5.bb 1.8 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152
  1. SUMMARY = "Document type definitions for verification of XML data files"
  2. DESCRIPTION = "Document type definitions for verification of XML data \
  3. files against the DocBook rule set, it ships with the latest DocBook 4.5 \
  4. XML DTD, as well as a selected set of legacy DTDs for use with older \
  5. documents, including 4.0, 4.1.2, 4.2, 4.3 and 4.4"
  6. HOMEPAGE = "http://www.docbook.org/xml/"
  7. LICENSE = "OASIS"
  8. LIC_FILES_CHKSUM = "file://${WORKDIR}/LICENSE-OASIS;md5=c608985dd5f7f215e669e7639a0b1d2e"
  9. # Note: the upstream sources are not distributed with a license file.
  10. # LICENSE-OASIS is included as a "patch" to workaround this. When
  11. # upgrading this recipe, please verify whether this is still needed.
  12. SRC_URI = "http://snapshot.debian.org/archive/debian/20160728T043443Z/pool/main/d/docbook-xml/docbook-xml_${PV}.orig.tar.gz \
  13. file://LICENSE-OASIS \
  14. file://docbook-xml-update-catalog.xml.patch \
  15. "
  16. SRC_URI[md5sum] = "487b4d44e15cffb1f4048af23f98208e"
  17. SRC_URI[sha256sum] = "b0f8edcf697f5318e63dd98c9a931f3fee167af0805ba441db372e0f17b2a44f"
  18. UPSTREAM_CHECK_URI = "${DEBIAN_MIRROR}/main/d/docbook-xml/"
  19. S = "${WORKDIR}/docbook-xml-4.5.c31424"
  20. inherit allarch
  21. BBCLASSEXTEND = "native"
  22. do_configure (){
  23. :
  24. }
  25. do_compile (){
  26. :
  27. }
  28. do_install () {
  29. install -d ${D}${sysconfdir}/xml/
  30. xmlcatalog --create --noout ${D}${sysconfdir}/xml/docbook-xml.xml
  31. for DTDVERSION in 4.0 4.1.2 4.2 4.3 4.4 4.5; do
  32. DEST=${datadir}/xml/docbook/schema/dtd/$DTDVERSION
  33. install -d -m 755 ${D}$DEST
  34. cp -v -R docbook-$DTDVERSION/* ${D}$DEST
  35. xmlcatalog --verbose --noout --add nextCatalog unused file://$DEST/catalog.xml ${D}${sysconfdir}/xml/docbook-xml.xml
  36. done
  37. }
  38. XMLCATALOGS = "${sysconfdir}/xml/docbook-xml.xml"
  39. inherit xmlcatalog
  40. FILES_${PN} = "${datadir}/* ${sysconfdir}/xml/docbook-xml.xml"